Jeep Renegade Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Anyone had any issues with the stop/start misbehaving? It started whilst out yesterday. Engine did not tirn off at lights. Turned stop/start off then on, all worked as normal. Same thing today, but on/off did not work, now have no stop/start at all. Looks like a trip to the dealer next week.
 

·
Registered
Joined
·
1,612 Posts
I had a 24 hour test drive of a 2.0 diesel limited last weekend. Sometimes it stopped sometimes it did not. I assumed there was something I was not used to causing it.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Hi, apparently brake pressure has to be within a certain range, and the battery charge above a certain level, but my driving hasn't changed, I'll see what it does tomorrow.
 

·
Registered
Joined
·
25 Posts
The stop/start stopped working while I was out on a test drive last week. The dealer who was in the car with me played it down as being an issue with the battery being a certain charge given the test car had not been driven for a few days and that all cars with this feature have this issue. I don't have enough experience with stop/start systems to know if this is correct but it sounded reasonable at the time...
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #7 ·
Well, turned A/C down to within 3 degrees of ambient temp, stop/start now working fine. Just wish this sort of thing was mentioned in the manual. Not knocking Jeep, I drove Volvos for years, before they turned into Mondeos, and their manuals were just the same. Maybe they should follow the computer industry, a quick start guide, then a more advanced manual on disc, or preferably in the glove box.
 

·
Registered
Joined
·
40 Posts
I have a TH and the stop/start is erratic, one day it works, the next it doesn't - this is on the same route. I am not running AC or heating. Turning the stop/start off then on has no impact.

Any ideas?
 

·
Registered
Joined
·
105 Posts
I have a TH and the stop/start is erratic, one day it works, the next it doesn't - this is on the same route. I am not running AC or heating. Turning the stop/start off then on has no impact.

Any ideas?
If the battery does not have sufficient voltage the stop start won't work, there are many parameters that will deicide if the stop/start will work or not, i.e. engine not up to temperature, high electrical load such as headlamps, heated windows, seats etc. A/C on as mentioned on previous posts.

If you only do a lot of short trips the stop start is unlikely to work, especially if you have your heated seats, lights on etc.

I find in the summer my stop start works every time but in the winter some times is does & some times not.
 

·
Registered
Joined
·
26 Posts
Hello,

When my car is standing overnight in the garage, the temperatur of the engine is fast on level and I have no problems with it. When it is parked outside, it takes a few moments before the engine is warm. When I standing at a red light while the motor is not warm yet, the start/stop is not working. I think it has to do with the temp. of the motor.
 

·
Registered
Joined
·
63 Posts
is the stop / start 'on' when the light is lit or 'off' when the light is lit ?
mine has not worked yet and the light is lit.

just done 100 miles and 4 days of ownership....already washed and waxed it ha ha.
 

·
Registered
Joined
·
40 Posts
Since my post in March I am now doing 30 miles a day in two 15 mile runs compared to about 15 miles a day back in March. I am still not convinced the stop/start works correctly. It now works more often than it used to, but is erratic; it will not work on the run in the morning then will work within two minutes of starting the journey home, and not work later in the same journey.

All I have on is the radio and the air temp is 15-20C.

Tomorrow the Jeep goes in for a s/ware update, will be interesting to see if there is any (positive) change.
 

·
Registered
Joined
·
52 Posts
I find ours a little hit and miss, I know if you set AC to max cool it wont switch off (manual AC not climate control). I did notice the voltmeter seemed equally erratic, I wonder if the two are connected?
 

·
Registered
Joined
·
40 Posts
Still not convinced all is well.

Last week the stop/start worked really well. I didn't drive the Jeep for two days this last weekend. Since then I have been doing my usual 2x15 mile trips every day at speeds up to 50mph. Start/stop hasn't worked once.

The s/ware update I had on 20 May only impacted instrumentation so I was told. They also checked the stop/start and didn't get any error codes = "it works".

Clearly it doesn't.
 

·
Registered
Joined
·
40 Posts
The stop/start only started working consistently after the first service in December 2016 when the system was reset. It has been working ok ever since, not quite sure how the car got out the factory if the stop/start didn't work or what could have happened to make it not work. Jeep offered no explanation - bit frustrating as it just like your home computer; when in doubt turn it off and on.
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top