Jeep Renegade Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
2016 Rene with the 1.4 turbo and 6 speed manual with 37,000 miles. In 5th or 6th gear I get a vibration-like sound (sound that would normally go with a vibration but without the vibration) while applying light throttle while cruising or maintaining speed. Back off the gas or accelerate in these gears and the sound goes away. Can't seem to figure out why this is happening or find any threads on the forum about this. Anybody have the same experience or know what might be causing this?
 

·
Registered
Joined
·
52 Posts
I don't have experience with this particular case but I would recommend you changing the transmission fluid, put in a good synthetic fluid, and you can also check if any metal shavings are showing up in the old fluid. You want to get those out if there are any to not cause damage. I have had other vehicles that would have notchy or overall not smooth shifting and putting a top notch synthetic made them a lot better. I have not done the fluid in the tranny in my renegade but have done it on many others and pretty straight forward with a drain plug on the bottom and a fill plug on the side you fill until it starts coming out. I assume the renegade is the same I usually do the fluid change at 50k intervals.

Sent from my Pixel 4a using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hmm... Might be worth the fluid change just to see what junk comes out of the tranny.
 

·
Registered
Joined
·
405 Posts
I have an almost "knocking" noise from 55-70mph when holding acceleration. As soon as I let off it stops. Not sure what it is at this point. Doesn't seem to be a rod knock, it's a pretty steady rhythm. Mine is from the front of the vehicle for sure, and it's just loud enough to be annoying.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Any thoughts on motor mounts? I hear they're a weak point. Maybe a bad mount could be causing the driveline to resonate through out the car?
 

·
Registered
Joined
·
405 Posts
Any thoughts on motor mounts? I hear they're a weak point. Maybe a bad mount could be causing the driveline to resonate through out the car?
I'm debating on bringing it into the garage after next weekend. I have a trip to Silver Lake Dunes planned. After that they can take a look and a drive and see if they can come up with anything. I'm at a loss. I'll let you know if get any new info.
 
1 - 7 of 7 Posts
Top