Jeep Renegade Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
so our new 2016 Trailhawk purchased in May now with 4211 miles on it, has been in the dealer since Wed morning, and will be there through Monday

wife was driving to work going around 60 and the Jeep started Bucking, rpms jumping, then the dash light up red with throttle body control error

she turned around came home and took our 14 year old Jeep liberty Renegade with 215,000 miles on it to work

the first day at the dealer they did computer updates, software updates, still couldn't figure out was was wrong, but they could duplicate the issue, keept it over night so the Tech could go over the manuals

next day they called said that it is the Throttle body and that they will have it in tomorrow,

well today, the put the new Throttle body in, Jeep went 4 feet now, has an active **** that they think the PCM fried the new Throttle body

thankfully have a rental car from them
sorry for the rant, hope this isn't a sign of things to come with this particular Jeep, I have never had any real issues with my other Jeep or Dodges, No repairs at all in the first 36k miles

Ps, now I am sure glad I sprung for the lifetime warrenty since I keep my vehicles for ever
 

· Registered
Joined
·
182 Posts
what month was your made in? just curious.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
what month was your made in? just curious.
I haven't forgotten this

just don't have the jeep back long enough to check


update

they had the Jeep for 7 days changed out the PCM and Throttle body, they drove it for around 65miles,
got it back next day, no issues
2nd day, dash lights up, put it in reverse, R just blinks, put it in drive D just blinks, can't get the jeep out of the garage
going to have to get it towed, but before doing that, went pressed start and throw it into reverse(didn't give the cpu a chance to think)

took it to the dealer, they said the Bcm Forgot what vehicle it was in, kept it over night
next day, they said 2 starts no issue, 3rd start same as before, now its day 3, and I expect them to keep it over the weekend as they wait to hear back from Chrysler

will update when it's fixed
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top