Jeep Renegade Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
50 Posts
How did this work out? I just brought my 2015 Jeep Renegade home from the dealership about 4 hours ago. It has about 135km on it and the message "Service Transmission" and the check engine light came on. I am extremely discouraged about this as this was my first car purchase.
 

· Registered
Joined
·
378 Posts
How did this work out? I just brought my 2015 Jeep Renegade home from the dealership about 4 hours ago. It has about 135km on it and the message "Service Transmission" and the check engine light came on. I am extremely discouraged about this as this was my first car purchase.
What was the build date on your car ? The sticker on the door should have this information. Your problem may be relatively minor so until your dealer looks at it don't be overly worried.
 

· Registered
Joined
·
50 Posts
What was the build date on your car ? The sticker on the door should have this information. Your problem may be relatively minor so until your dealer looks at it don't be overly worried.
I have no idea as I haven't had the car in my possession for 2.5 weeks now. It has had the valve body replaced, and once that was done the car wouldn't start and they realized the wiring harness was crushed so that is the problem they are currently attempting to fix.
 

· Registered
Joined
·
50 Posts
What was the build date on your car ? The sticker on the door should have this information. Your problem may be relatively minor so until your dealer looks at it don't be overly worried.
I posted a thread about my Renegade called Valve Body Replacement today if you want the complete background on my car. It has currently been in the shop since August 14th. I went to the dealership, yet again, today to see how things were going. They replaced the wiring harness as it had been crushed, but they still couldn't get the car to turn on. About 10 minutes before I got there, they got it on, but it is currently stuck on and in reverse. The computer and the transmission are not communicating properly as one is seeing the car in reverse and one is seeing the car is park.

While I was there I got the build date on the car and it is June 26, 2015.
 

· Registered
Joined
·
377 Posts
I have no idea as I haven't had the car in my possession for 2.5 weeks now. It has had the valve body replaced, and once that was done the car wouldn't start and they realized the wiring harness was crushed so that is the problem they are currently attempting to fix.
Where was the crushed wiring harness located? I'm having the service transmission warning, but service dept is closed until monday.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top