Jeep Renegade Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I'm a recent owner of a Renegade Limited 1.4 auto, previous vehicle hyundai ix35.
So far so good , until today that is. Started up this morning to discover the satnav and everything else on the infotainment system had changed to Italian, causing much laughter in the house & the car. Handbook not much use so decided to get to the dealer using the postal address which was duly keyed into the satnav which proceeded to direct me , yes you guessed it, in Italian. not much use in an area i'm not very familiar with. Got there eventually, service desk had not heard of the problem, but service manager had. Result is the toaster is booked in for a software update next Tuesday which will take many hours. Anyone else had this? Googled it & the fault is known by Jeep.

Scouser
 

·
Registered
Joined
·
7 Posts
Hi, I'm a recent owner of a Renegade Limited 1.4 auto, previous vehicle hyundai ix35.
So far so good , until today that is. Started up this morning to discover the satnav and everything else on the infotainment system had changed to Italian, causing much laughter in the house & the car. Handbook not much use so decided to get to the dealer using the postal address which was duly keyed into the satnav which proceeded to direct me , yes you guessed it, in Italian. not much use in an area i'm not very familiar with. Got there eventually, service desk had not heard of the problem, but service manager had. Result is the toaster is booked in for a software update next Tuesday which will take many hours. Anyone else had this? Googled it & the fault is known by Jeep.

Scouser
This happened to me last week, I was driving, the dash lights flashed, everything reset to Italian and metric for units. I had to pull off the road and stop to be able to get to all the settings, the unit still said it was in English. I had to put it in Spanish (next language on list) and put it back to English to get it to work right. Besides the imperial to metric switch a bunch of other settings reset also...... auto parking break, radio on after key off, auto wiper.... those type settings.
I had the jeep into the dealership yesterday for its first oil change, I made sure to have them check it so that it was documented. The answer was the stock "couldn't duplicate, no tsb's, no info from jeep on subject, wait and watch for it to happen again'.


Sent from my DROID RAZR using Tapatalk
 

·
Registered
Joined
·
1,212 Posts
Hi, I'm a recent owner of a Renegade Limited 1.4 auto, previous vehicle hyundai ix35.
So far so good , until today that is. Started up this morning to discover the satnav and everything else on the infotainment system had changed to Italian, causing much laughter in the house & the car. Handbook not much use so decided to get to the dealer using the postal address which was duly keyed into the satnav which proceeded to direct me , yes you guessed it, in Italian. not much use in an area i'm not very familiar with. Got there eventually, service desk had not heard of the problem, but service manager had. Result is the toaster is booked in for a software update next Tuesday which will take many hours. Anyone else had this? Googled it & the fault is known by Jeep.

Scouser
Hello scouser,

I’m sorry to hear about this concern you are having! Your dealership will be best able to assist you with this issue. I’d be happy to follow-up with them once you drop your Renegade off next Tuesday. Send a PM to our page with your VIN if that is the case!

Andrea
Jeep Social Care Specialist
 

·
Registered
Joined
·
116 Posts
I haven't had that issue, however anyone having issue with Bluetooth not connecting randomly?
It seems to occur more frequently when I do remote start. I notice the icon for Bluetooth will not come on. I basically have to turn off Bluetooth on my cell, then back on again for UConnect to get the Bluetooth connected icon.
As I said, intermittent, and I am sure when I take to the dealer won't be happening.
Just wondering if anyone else had issues. My Renegade is just over 1 year old...and I had applied two UConnect Updates.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top