Jeep Renegade Forum banner

61 - 73 of 73 Posts

·
Registered
Joined
·
408 Posts
Discussion Starter · #61 ·
The dealer has open cases with Chrysler. He said he also had someone come in on Saturday with a Renegade having the same problem. So it’s clearly a wide spread problem and will probably become a recall.
Good to know that we're not the only ones, and that at least Jeep Corporate seems to be aware of the issue. Though I'm not sure if this will ever reach the level of a recall, which is generally for safety-related issues. But a software update would be nice...

The technician did show me how to turn off the turn by turn on the instrument cluster. So now when we use our navigation it won’t show turn by turn on the cluster display.
Yeah, the feature can be disabled. That's just not a solution.

I am leaving mine on for now and just cancelling it when it gets stuck.
That's what I'm doing. I like the feature, and I'll suffer through having to manually cancel it when necessary.
 

·
Registered
Joined
·
408 Posts
Discussion Starter · #62 · (Edited)
I just got another e-mail from Fredy at Uconnect customer service (they really do seem to be keeping on this).

He says that there will be a (software, I assume) update to the Instrument Cluster hopefully by the end of 2nd Quarter.

Nothing about whether they've identified the problem and its cause, and whether this update is supposed to fix it -- but that's what's implied. But it does sound like the issue isn't with the radio/nav system, but with the instruments communicating with it.

I wonder if this is the update that the Jeep Cares rep here was saying had been expected in early 2nd Quarter?

Meantime, it's still not clear to me how we'll be notified of the update, and how to get it downloaded... wirelessly, or through the dealer?
 

·
Registered
Joined
·
22 Posts
I just got another e-mail from Fredy at Uconnect customer service (they really do seem to be keeping on this).

He says that there will be a (software, I assume) update to the Instrument Cluster hopefully by the end of 2nd Quarter.

Nothing about whether they've identified the problem and its cause, and whether this update is supposed to fix it -- but that's what's implied. Bu tit does sound like the issue isn't with the radio/nav system, but with the instruments communicating with it.

I wonder if this is the update that the Jeep Cares rep here was saying had been expected in early 2nd Quarter?

Meantime, it's still not clear to me how we'll be notified of the update, and how to get it downloaded... wirelessly, or through the dealer?
Fredy actually called me yesterday but I did not recognize the phone number so it went to voicemail. I called him back and got his voicemail so no direct contact yet. My car goes to the dealership on Thursday.
 

·
Registered
Joined
·
408 Posts
Discussion Starter · #64 ·
I've never noticed it popping up except after the respective turn.

But you know, now that you mention it, each time I remember, it's been that same 90-degree right-hand turn image. I don't remember it not canceling after any other kind of turn... and I'll have to pay attention as to whether it ever pops up by itself...
Well, it's not just the 90-degree right-hand turn. It'll get stuck on all sorts of turns -- left, right, half-left or -right, acute... But always after the turn -- it never pops up on its own.

By the way, Fredy e-mailed me again; saying since the update will be to the instrument cluster (not the radio), it'll be through the dealer.

But no assurance that they've found the fault, and that this update will fix it...
 

·
Registered
Joined
·
22 Posts
My car was at the dealer for two days. There were other issues but they could not find anything wrong. They are going to replace my radio. I don't think that will fix anything. I had a loaner 2021 Renegade with Nav and it did the same thing as my Renegade. Fredy has called me twice now but we have not connected yet. I emailed him yesterday.
 

·
Registered
Joined
·
408 Posts
Discussion Starter · #66 ·
They are going to replace my radio.
So the dealer was able to replicate the problem? That's one thing I'm worried about -- that when I take it in, it's going to decide to behave perfectly...

Replacing the radio/head unit sounds pretty radical, and expensive for Jeep -- particularly since it sounds like they're just guessing that's the problem. Like I said, Fredy seems to be implying that it's the software for the instrument cluster, though I'm still trying to get him to confirm that. That may be a guess on their part too... Still, I do think it's a software problem somewhere...
 

·
Registered
Joined
·
408 Posts
Discussion Starter · #67 ·
Well, not entirely encouraging news.

I'd e-mailed Fredy at Uconnect Customer Service, specifically asking whether the techs had identified the issue and whether they thought the Instrument Cluster software update would fix it.

He replied, "Basically, it's something I would say is a matter of retesting after the update, honestly."

So it sounds like they're guessing. Or, worse, just hoping... Or, worse yet, just hoping we'll all just go away...

Anyone else have anything back from Jeep?
 

·
Registered
Joined
·
408 Posts
Discussion Starter · #68 ·
Another reply from Fredy with Uconnect Customer Service today.

He wrote, "It's not just hoping, the engineers are the ones saying to wait for the update and then re-test. Usually that means, they think it will address the concerns."

So more than just hoping, but doesn't exactly sound like engineering certainly... On the other hand, I'm sure the engineers aren't keep the customer service reps completely in the loop either....

Has everyone with this issue documented it to Jeep, one way or another?
 

·
Registered
Joined
·
22 Posts
Another reply from Fredy with Uconnect Customer Service today.

He wrote, "It's not just hoping, the engineers are the ones saying to wait for the update and then re-test. Usually that means, they think it will address the concerns."

So more than just hoping, but doesn't exactly sound like engineering certainly... On the other hand, I'm sure the engineers aren't keep the customer service reps completely in the loop either....

Has everyone with this issue documented it to Jeep, one way or another?
I also got an email from Fredy today. He wants to know what my issue is so I will email him with details.
 

·
Registered
2021 Jeep Renegade Limited w/ Sun/Sound group
Joined
·
20 Posts
Hey guys, I've been away for a bit....

Starr your loaner did the exact same thing? I knew it! I swore early on that if I would go test drive a 2021 with NAV it would have the same problem. Mean while, despite the loaner doing the same thing they still want to replace the radio? Nuts!

Well Fredy told me about the upgrade as well, and that I would have to go in to have it done. I'm not holding out much hope but maybe they'll surprise me.
 

·
Registered
Joined
·
408 Posts
Discussion Starter · #71 ·
I had a loaner 2021 Renegade with Nav and it did the same thing as my Renegade.
Starr your loaner did the exact same thing?
Oh... I didn't notice that in starr's post. That makes...how many 2021 Renegades with Uconnect 4C NAV, where this is happening?

It's got to be a systemic issue, and Jeep/Uconnect have got to be aware it's not just individual customers who are having the problem. And I don't think blindly replacing the (very expensive) radio will fix this...it looks like a software issue to me. So that actually makes me hopeful this upcoming update might fix it...
 

·
Registered
Joined
·
22 Posts
I don't think replacing the radio makes sense at all. So I am not going to pursue it unless the dealer contacts me about it.
 
61 - 73 of 73 Posts
Top