Jeep Renegade Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
285 Posts
I loaded up some mp3's on a USB stick. It plays the songs but when I browse by artist or song it says "Loading" but does not do anything. Is there a bug in the software ?
Do you have the songs in folders by artist/genre? Or are they all single files in the root directory?
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #3 ·
Do you have the songs in folders by artist/genre? Or are they all single files in the root directory?
I have the songs by artist. Each artist has his own directory. I can use the < and > buttons to advance songs but it just seems to go on forever with "Loading" when I browse. Its only a 4GB key with less than half of it used. Unless Uconnect 5.0 has a really slow processor I would have expected it to browse quite fast. My research has shown that Uconnect 5.0 operating system is written by Microsoft so I would not be surprised if it is buggy.
 

·
Registered
2015 Trailhawk
Joined
·
845 Posts
Some players have limits on number of folders, character count, etc... I have no idea if that is the case here, but I would re-do the USB drive with just 5 albums and see if it performs better (or at all). As you increase the number you may find a cutoff point. Just a thought.
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #5 ·
Some players have limits on number of folders, character count, etc... I have no idea if that is the case here, but I would re-do the USB drive with just 5 albums and see if it performs better (or at all). As you increase the number you may find a cutoff point. Just a thought.
Good point. I will try that and see if it makes a difference. If anybody else has experience with Uconnect 5.0 and mp3 files please post.
 

·
Premium Member
Joined
·
3,154 Posts
Oh. I was going to use a 128GB USB and load all my cds on to it. I have many many cds and would group them into artists names, eg AC/DC, Alice Cooper, Led Zeppelin etc. I got an 8GB USB here so I will try that first and see what happens, before I shell out for a 128GB stick.

Glas I found this thread.
 

·
Registered
Joined
·
89 Posts
When I load in a USB drive it takes a couple minutes to index originally and then subsequent times when I start the car it works right away.

I second the idea of formatting the drive and then adding a few albums and see how it compares.
 

·
Registered
Joined
·
1,624 Posts
I copied the entire music directory from my iTunes folder on my computer to the mini-thumb drive. It works flawlessly and without any delay or lag. I leave it plugged in all the time.

I'm guessing I have about 600 songs and maybe 50 or 60 albums in total on the drive. Each album with its songs is in a separate directory. Nothing else is on the drive which is 16 GB (I think).
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #9 ·
I copied the entire music directory from my iTunes folder on my computer to the mini-thumb drive. It works flawlessly and without any delay or lag. I leave it plugged in all the time.

I'm guessing I have about 600 songs and maybe 50 or 60 albums in total on the drive. Each album with its songs is in a separate directory. Nothing else is on the drive which is 16 GB (I think).
This is interesting. Do you have Uconnect 5 or 6.5 since I believe 6.5 would have a faster processor and more memory since that unit supports NAV. Also did you format as FAT or NTFS ?
 

·
Registered
Joined
·
1,624 Posts
This is interesting. Do you have Uconnect 5 or 6.5 since I believe 6.5 would have a faster processor and more memory since that unit supports NAV. Also did you format as FAT or NTFS ?
I have the 5.0 in the Renegade. I didn't format the thumb drive at all; I just copied the files onto it fresh out of the package.

I'm running Windows 7 on a PC.
 

·
Registered
Joined
·
78 Posts
Uconnect 3.0 worked, but not 5.0

I get the same problem with the 5.0. It plays and I can move forward or back in sequential random order, but no browsing. It's a 32 Gb with 7000 songs in 8 folders by genre. When I tried it in a Uconnect 3.0 renegade at the dealer, i got browsing in a couple of minutes.
 

·
Registered
Joined
·
1,212 Posts
[/LEFT]
I get the same problem with the 5.0. It plays and I can move forward or back in sequential random order, but no browsing. It's a 32 Gb with 7000 songs in 8 folders by genre. When I tried it in a Uconnect 3.0 renegade at the dealer, i got browsing in a couple of minutes.
Hi Wade,

Generally we recommend having no more than 255 songs per folder, and up to 8 folders, for the current Uconnect configuration. It's possible this may be linked to the issue you're experiencing. The Uconnect team can also dive a little further into this with you if you give them a call at 1-877-855-8400 (available 24/7).

Kori
Jeep Social Care Specialist
 

·
Registered
Joined
·
18 Posts
No problems with my Uconnect 5 now. I have a 64GB stick which has around 60 folders, with at least 25-30 tracks in each folder.

The only problem I had initially was that some of the mp3 files didn't have the information "inside". When you right click an mp3 in windows and select properties, it comes up with all the info, Artist/Album/Year etc.

I thought at first it was only the filename which it needed, but it actually reads all the "hidden" info.

Hence now, on several albums, I had to manually change the info for each mp3 file to get uconnect to recognise all the music, as some tracks were completely blank of info.

For example, if I took 20 random tracks I wanted to make into an "album", rather than just put them in to a separate folder, I had to manually go into each tracks info and make sure each track had the same album name.
 

·
Registered
Joined
·
78 Posts
Hi Kori,

Thanks for the support. You suggest 255 songs per folder and 8 folders for media play.

This implies about 2024 tracks max for Uconnect 5 usb media, otherwise it hangs on "please wait".

I called Uconnect support and they told me it will only play mp3 and mp4 files, otherwise it will 'try forever' to read the data from "unsupported files". Also it will "only read up to 4 folders with up to 1000 tracks per folder" and It has "no storage or hard drive" for storing songs or track data.

I don't know if there is a way to make product suggestions or if developers get any feedback, but these are significant limitations. I moved my usb device from my $99 Kenwood in dash in my 03 Focus to my new Jeep and it will not browse the music.

I suggest improvements to the software;

1) If I hit the "browse folder" selection, just read the folder titles, not the whole device.

2) it could say "Loaded XXXX songs" and proceed to allow browsing, rather than hanging.

3) If the file has no data on the track title, etc., skip it.

Q. Why did Uconnect 3.0 work on the same usb device?
 

·
Registered
Joined
·
78 Posts
No update for my VIN.
 

·
Registered
Joined
·
78 Posts
Well I guess some of the info provided to me by Uconnect was hookum, I was able to completely fill my 32 Gb usb storage device with about 7000 files in 12 folders and browse it after a few minutes of "please wait". The only rules I followed was less than 1000 files per folder, mp3 only, and a playlist for each folder in the root of the drive. Not all files have complete album, artist, genre info included, which are shown as 'unknown' while browsing and blank on the 'now playing screen'. This is a big relief. Along the way I got streaming music from my phone through bluetooth working with amazon music on my moto g.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top