Jeep Renegade Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
2015 latitude

started yesterday morning, but every 5 minutes or so, screen shuts off audio cuts out and 30 seconds later it reboots. I’ve already disconnected negative terminal on battery for 5 minutes and that did not resolve issue. Drove for a bit this morning and issue is still persisting.

anyone have a solution for this issue?
 

·
Registered
Joined
·
4 Posts
I have the same issue on my 2015 Latitude with the Uconnect 5.0. It started about two weeks ago as well. I will be driving and approximately every 5 minutes or so, the radio shuts off and then reboots after maybe 5-10 seconds. But, while in the temporary off mode, the backup camera still works, so the unit does have power going to it. I tried disconnecting my battery overnight and this did not fix anything. I really hate to be going to the dealer for this. My Renegade has never been to a dealer since I bought it new and and this is pretty much the only big issue I've had so far.
Since I bought my 2015 new in 2016 as a leftover, I would assume the Uconnect was updated prior to me taking delivery of it. I don't recall seeing a way to check the version number of the software in any of the menus and I can't remember if I did an update myself on this vehicle as I have other vehicles with various types of Uconnect systems. I downloaded the update and will try when I get a chance.
 

·
Premium Member
Joined
·
3,186 Posts
You need your Vehicle Identification Number (VIN) and then google Uconnect website or search within the forum. Enter your VIN and it will tell you what you have and what upgrades are available. Download any updates onto a pen-drive/usb drive and insert into the USB port on your dashboard to update.

In this instance it told me my update number I have no updates available in my 2015 model.

If my info is wrong I do apologise but it really is that easy to find your updates.

There is also a current identical topic to yours that is running. I replied in there about how to search for a further current 2 day old topic on how to reset your radio.

ps: VIN can be found on the bottom of your windscreen inscribed on the black rectangular plate. if not then there is a small flap on the door sill, in my case it's on the right hand door (UK). Lift the flap and it should be in there.
 

·
Registered
Joined
·
1,071 Posts
The Neighbor-
Like others have said, it may be dealer time. At this point, since you said you've never been back to the dealer since purchase, I'm sure you have several software updates available. One of them may fix your issue.

But be advised, don't be in a rush when you get to the dealer; it may take a long time to update everything. Like hours. And to be safe, bring ALL key fobs with you. Odds are extremely high they won't need them, but if they have to re-flash something, it's vital to have all married key fobs with you.

The days of buying a vehicle and kissing the dealer good bye is long over. These vehicles are software driven and the programs need to be updated every now and then, just like your home computer....
 

·
Registered
Joined
·
4 Posts
I knew it wasn't my radio. It was my OnePlus phone that I updated to Android 11 a couple weeks ago. I unpaired my phone and the problem went away. I paired it and it started the off-on cycle again. OnePlus is working on it according to the link below.

 
1 - 9 of 9 Posts
Top