Jeep Renegade Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I posted on this topic before but as I was locked out with the password debaucle I had to start a new account

Uconnect. Apps dont work. Tried registering numerous times and get a message that It cannot connect to the server. Took it back to Jeep and they "fix" it. Still cant connect. They blame the area Inam trying to connect from and a lack of seevice. Uconnect said that the VIN doesnt match. I gave up.

Today my Sirius shuts off after just 2 months. Call them. They tell me that the radio ID doesnt match the VIN and that I only qualify for a used car trial of three months not a 12 month new car trial.

Heading to the dealer tomorrow to see whats up, anyone else have this issue?
 

·
Registered
Joined
·
1,212 Posts
I posted on this topic before but as I was locked out with the password debaucle I had to start a new account

Uconnect. Apps dont work. Tried registering numerous times and get a message that It cannot connect to the server. Took it back to Jeep and they "fix" it. Still cant connect. They blame the area Inam trying to connect from and a lack of seevice. Uconnect said that the VIN doesnt match. I gave up.

Today my Sirius shuts off after just 2 months. Call them. They tell me that the radio ID doesnt match the VIN and that I only qualify for a used car trial of three months not a 12 month new car trial.

Heading to the dealer tomorrow to see whats up, anyone else have this issue?
Hi Indyrenegade2,

It sounds like there might be something amiss with your information--maybe a difference in what we at FCA have on file and your UConnect information? Do you have the app on your phone as well? Sometimes if the info is not exactly the same as what the vehicle was registered with, it gets messed up. Let me know what the dealership is able to find out for you.

Kori
Jeep Social Care Specialist
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top