Jeep Renegade Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Uconnect on my trailhawk won't recognize my iPhone 6. It charges, but the screen says nothing is connected, and I can only connect via Bluetooth. Tried turning off bluetooth, USB still doesn't see the phone. Anyone else having this problem? Any solutions? Thanks!
 

·
Registered
Joined
·
52 Posts
My IPOD 4 80 Gig connects fine if I use the original Apple version of USB cable but once I connect with an aftermarket one I bought I either get a lot of static at low volumes or it can't read the titles. I would try it with another USB cable if you have one.
 

·
Registered
Joined
·
35 Posts
I have the same issue. USB is recognized about 1/3 of the time. I am using the USB jack that sits under the climate controls. I have tried turning the system off, plugging/unplugging, having it connected when starting the vehicle, and other things. iPhone 6, iOS 8.4.1

The only thing that seems to work most of the time (Without having to stop/restart the engine completely) is going to the Phone\Bluetooth settings, hitting Paired Audio Devices, and Disconnect. Then, with the USB cable already plugged in, about 2/3 of the times I try this, it finally detects USB as a valid source. I have managed to see both USB and Bluetooth both available as a Source about once, ever. The connection seems to be charging at all times, despite what the Audio Source is doing, so I know part of the cable is working. I will be trying another cable, just in case, as USB cables can certainly be very funky too.

Yesterday, the music I was playing from the iPhone, USB Source, kept pausing when Google Maps would attempt to voice navigation direction, but no sound would play. The music would then remain paused. That same trip, after being stopped at the dealership for a while, everything worked fine after restarting the Renegade. Nav directions were spoken with the music merely lowering in volume for the direction, then returning to the correct volume. No pause or any other odd behavior.

Needless to say, the intermittent nature of the connection is making me nuts. Granted, the only thing that seems any different is not being able to see the Album Artwork in the display when the Audio Source is Bluetooth, but it still makes me nuts.
 

·
Registered
Joined
·
1,212 Posts
beth2154,

As NHDon mentioned, it could be the cable as well. You could see if that makes a difference. Otherwise, I would recommend seeing if it's possible for a local dealership to test it with a similar phone. Please keep us posted on this!

AlbinoRhino,

Have you had a chance to test it with a different cable yet?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
Ok...so I tried another apple cable and I just got the usb in the dash to work! Same cable in the center console doesn't connect though. What a pain in the rear end. I'll keep trying more cables to see if I can get one that works for both ports.
 

·
Registered
Joined
·
35 Posts
The port in the arm rest might be charge-only in your TH.
I do see that *my* TH specifically says Charge Only for the Armrest USB port, both on the dealer sticker and the icon at the charger port itself, if I recall. So the OP should check the markings at the port maybe?

I have not had a chance to try a different cable yet for my intermittent USB recognition issue, but it has been better over the last couple of days. I have been careful to ensure that the sound system is OFF, then I plug in the iPhone cable, I get the 'Charging' ding and indication. Then I start the Renegade and USB/iPhone is detected and works. If I press the Media button again, it switches to Bluetooth (as it should) and I can not get USB back until I either disconnect Bluetooth from the Audio Devices selection->Disconnect Device, or restart the vehicle.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #14 ·
The different cable completely fixed my issue. All of my cables are genuine apple, but for some reason, only one works. But there are no issues with having to switch in and out of Bluetooth or restarting anything. Try all the cables you have, apparently it's very touchy!
 

·
Registered
Joined
·
1,212 Posts
The different cable completely fixed my issue. All of my cables are genuine apple, but for some reason, only one works. But there are no issues with having to switch in and out of Bluetooth or restarting anything. Try all the cables you have, apparently it's very touchy!
Happy to hear you got this resolved! Thanks for following up!
 

·
Registered
Joined
·
78 Posts
I had the same sort of issue with both my USB ports in my Limited - a software update from uConnect solved the issue and added extra functions like Siri Eyes Free so now I can set reminders - send txt - get weather updates and even control Apple music to find my fav tracks.

Go here and enter your vin in and do the software update - https://www.driveuconnect.com/software-update/
 

·
Registered
Joined
·
1 Posts
Seems similar to my problem. Something happened to my Renegade Latitude's 2 USB ports last week. Until then, I used the front one to charge my Sony Xperia smartphone, and the central one in the armrest box to play music from my iPod Touch. The iPod stopped playing in mid song and now neither USB port will sync my iTunes music to the media center, but will still charge my devices. Have tried two different Apple lightning leads, but no joy. The media center no longer recognises any USB device plugged in.
 

·
Registered
Joined
·
78 Posts
this might also be worth a try.

The other week I could not get my music to play on the uConnect unit but for some reason the music would come out my phone and the head unit could control the play. This after it being working fine for months. A turn off of the phone and back on again ( hold power button down till you get slide to turn off ) seem to solve the issue - been working fine since

Worth a go
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top